Solve svchost.exe high CPU usage in Windows 7 [How To]

If you are using Windows 7 64-bit (Professional), and you are having the same problem as I have, you are in the right place. Occasionally I found that my Windows svchost.exe using high CPU usage, and it doesn’t seems to reduce/stop even after some time. Thus I decided to see which services are linked to that particular svchost.exe.

1) Run Task Manager. (Ctrl+Alt+Del)

2) Under Processes, sort all the program with Image Name (clicking on it).

3) Look for the culprit (High CPU usage). Right click on the svchost.exe > Go to Service(s). image

4) It will highlight the services linked to the selected svchost.exe.

image

In my case, I found upnphost to be the culprit of the all-time-high CPU usage. Once I stop the service by right click on it > Stop Service, my CPU no longer at high level of usage. But it did occur again on the next reboot. Thus, if you aren’t using any devices/special services that utilize uPnP Device Host, I would recommend to disable the service. How? (You make the call either to disable it or not)

1) In Task Manager, under Services tab, click on Services… button at the right bottom of the window.

image

2) Look for uPnP Device Host, then right click on it > Properties.

image

3) In the drop down menu for Startup Type, choose Disabled (or other option as you wish). Then click OK. And you can quit Services window after it is disabled.

image

By disabling the service, my PC Windows 7 has no more high CPU usage by svchost.exe. I am still unsure about the real reason behind the problem, but several findings on the Google suggest that it has something to do with Internet Explorer. Anyway, hope this can help you if you facing the same problem.

About these ads

64 thoughts on “Solve svchost.exe high CPU usage in Windows 7 [How To]”

    1. Hi Alonso,

      Please check if you have the ‘Show processes to all user” ticked, it will show all the processes including the svchost.exe. Hope you can find it.

      Rgds,
      Taylor

  1. guess i think it has to do with internet explorer. some other issues over different drivr. After i did that, suddenly it fell so down…. keep posting if it have some other issues with other programs

    1. Hi Kanamanim,

      Yes, it could be related to some other executable since svchost.exe has a lot of different variants. Glad you find the culprit for your problem. Keep posting if you found anything useful for us. :)

      Rgds,
      Taylor

    1. Hi Sayeed,

      Are you sure you did all the steps correctly? Is it possible for your to screenshot your task manager?

      Rgds,
      Taylor

  2. I also have had an issue with svchost.exe causing 100% cpu usage. The services in question related to svchost are NLASvc, LanmanWorkstation, Dnscache, and CryptSvc. My problem ended up being Firefox. In the latest version they added plugin-container.exe which runs as a process separately from Firefox. The idea behind it is if a plugin crashes it wont crash Firefox or your browsing session. But it made surfing on my system unbearable.

    The solution: Disable plugin container process.

    Open Firefox web browser.
    Type about:config in the address bar and press Enter key.
    A warning will appear. Ignore it and press the “I’ll be careful, I promise!” button.
    In the Filter field type dom.ipc. Six preferences will appear for the filter dom.ipc.
    Ignore first and last preferences (dom.ipc.plugins.enabled and dom.ipc.plugins.timeoutSecs). Toggle (double-click) each of the four remaining preferences to change the value from “true” to “false“.

    You are done, restart Firefox and open up Windows task manager to see that the plugin container process is disabled..

    More info,
    The crash protection feature in Firefox 3.6 is enabled for certain plugins only. The four preferences that we modified here specifies four different out-of-process plugins. They are the the NPAPI test plugin, Adobe Flash, Apple QuickTime (Windows) and Microsoft Silverlight (Windows). These plugins are specified in a separate dom.ipc.plugins.enabled. preference by default is set to true. We can disable them by changing their value to false. And thus plugin-container.exe will not run. By default the preference dom.ipc.plugins.enabled is already set to “false”. So, no need to touch it. The dom.ipc.plugins.timeoutSecs is also not important here as other values are false.

    Hope this helps.

  3. Hi,
    I am facing a similar problem. A particular svchost.exe file that constantly using up loads of memory. Its using the following the services..
    1. wudfsvc
    2. UxSms
    3. TrkWks
    4. SysMain
    5. PcaSvc
    6. Netman
    7. HomeGroupListner
    8. hidserv
    9. CscService
    10.AudioEndpointbuilder

    These are the services. I did a background check and found out more about them but i don’t know whether or not I need them or not. Could you help me. Its screwing my pc…

    Thanks.

    1. Hi Simon,

      Since you already did some research on them, most likely you will know which is needed for your PC. However, to test out which service is hogging the resources, try disable one by one. You will eventually find out which is the culprit. Don’t worry, by turning off them won’t cause permanent effect to your Windows, after a redraft everything will be back to normal.

      Try it and let me know if it helps.

      Rgds,
      Taylor

    1. Hi Kenneth,

      Are you the administrator of the computer? It would require administrator right to stop the running services if not mistaken.

      Rgds,
      Taylor

  4. This svchost.exe takes almost 100% of my CPU time whenever I open Windows Media Player. I actually discovered that this service was the culprit and, wanting to know more about this service, ended up at this article. It’s good to know you’re not the only one with the same problem :D

    1. I had the same issue for me as well. “UPnP Device Host” was the culprit in my svchost.exe causing high 98-99% CPU usage.

      It appears by itself when in normal computer operation, appearing almost on instant when starting WMP12. I’m running Windows 7 32-bit, it’s weird I never had this prior fall 2010 and now it became a common issue. Thinking it might be a Windows Update, but it’s too far late to check that with so many updates now installed on my computer…Will try to investigate further when I do a clean re-install for SP1. ;-)

  5. Hi,
    When I click on… go to Services, it will highline nothing. And I am running windows as administrator. Can you give advice? thanks

    1. Hi,

      Do you select the ‘Go to Service(s)’ for svchost.exe? Some other exe file might not have a service associated, but if you selected svchost.exe, I am pretty sure there will be some services associated and highlighted in the Services page. Can you please check again? Thanks!

      Rgds,
      Taylor

    1. Hi,

      That’s a little bit strange if you did disabled all the services running by that particular svchost.exe. I suggest you get SysInternal to have a depth look into the culprit causing your problem.

      Rgds,
      Taylor

  6. Thanks for the tip, this helped me find the errant service, which was Akamai. I have been fighting this for 2 weeks.

    Many grats.

  7. Hi there.

    I’ve followed all the steps, and disabled all services from svchost.exe, except one: The wudfsvc.dll, which is the Windows Driver Foundation thingy. How do i solve that? I can’t disable it since its needed for my system to work :o

    - Nick

    1. Hi Nick,

      The idea is not to disable all the services in svchost.exe, but rather to catch the one causing the high CPU usage. If you have already stop the high CPU usage before disabling wudfsvc.dll, you can just ignore it.

      Rgds,
      Taylor

      1. Hi again.

        The problem is, that even though i’ve disabled all the svchost.exe services (Except the wudfsvc.dll), it still uses 50-100% of my CPU.

        Something weird though, is that after around 20min, the CPU usage goes down to normal (Even without my interference).

        Is it possible that the wudfsvc.dll is using the high amout of cpu power?

        Thanks
        - Nick

  8. nick, the process u mention is the windows update found.server…. , and is not critical, u can update manually or leave it on now n then, and yes it might very well be ur suspect. try stopping it and check ur cpu % – if lucky, thats all, if not, you have a worm that uses the service host process to do its thing undetected. For me it was both. Working on the worm now – anyone new on here, please comment.

  9. Perfect! Thank you so much. Funny, it was the upnp host that was giving me trouble too. Thanks for the tip on locating the offending service. Testing the computer now with it disabled, hope all is well.

  10. it has nothing to do with IE, it has to do with downloading on any browser; i use chrome, and this stuff happens when i am watching HD videos on Youtube. it’s the upnphost service in my case also.

  11. One issue with the “its fault of internet explorer”
    When i start my pc, i have about 100% cpu usage because of svchost.exe, but FireFox is my standard browser and i never even open internet explorer.

    I don’t really understand how the hell that is possible.
    Windows is a multi billion company, they should fix this ?!

    1. Hi John,

      Not knowing the real cause of the issue and turn into formatting is not something I recommended, unless you are aware that format will be the only solution. Sometimes some applications installed can cause this problem, which I think cannot blame Windows entirely. The same problem can occur after format if the real cause is unknown.

      Rgds,
      Taylor

  12. Hi Taylor.

    After going to the Service section i discovered the following being linked to the svchost.exe

    wudfsvc
    UxSms
    TrkWks
    SysMain
    PcaSvc
    Netman
    HomegroupListener
    hidserv
    CscService
    AudioEndPointBuilder

    Do you have any idea wich of theese may cause my cpu usage to rise ?
    It’s not 100 % like most of the comments in here, but its still between 50 and 70 %.

    Hope I was able to make my self understandable since english is not my strong side in writing :)

    Kind regards

    Kasper

    1. Hi Kasper,

      Sorry for the late reply. Frankly, I have no idea which can cause the high CPU usage, but if you are not in a HomeGroup, you can turn HomegroupListener off. I would try to switch them off one by one to identify which is the culprit – no worry, by turning them off, it won’t make your Windows unusable, a restart normally can restore everything.

      Rgds,
      Taylor

  13. Myself using XP having similar problems — however svchost CPU usage is constant at 20%.

    I finally drilled it down to UPNP again. However XP doesn’t have “UPnP Device Host” so I didn’t know how to fix it… then I disabled UPnP on the router which did the trick.

    svchost CPU constantly 20% -> nowadays 1-2%

  14. i wanna know if its a virus or what.. i have 12 processes of svchost.exe , one of them is using 110k CPU…………thanks .and sorry for my bad english

  15. I have the same problem, but in my situation svchost doesn’t deal with any service, so I can’t just disable annoying service. The problem ocured after installation of Google chrome … only deleting of browser didn’t give results (it would be great if it were so easy :)

  16. When I clicked go to services on svchost.exe it shows up Power, DCOM Server, and Plug and Play. I already have problems that these services would shut down by itself and restart my computer. But these take so much CPU that all processes would lag or run slowly. Any help? I am running a genuine copy of Windows 7 Home Premium 32-bit but my computer is originally running Windows Vista.

    1. Hi,

      I would like to think that there are some third party software actually cause this, do you already have the same issue on fresh install of Windows 7?

      Rgds,
      Taylor

  17. Hi Taylor.

    After going to the Service section i discovered the following being linked to the svchost.exe

    BFE
    DPS
    PolicyAgent
    XLservicePlatform
    StiSvc
    FDResPub
    FontCache
    SCardSvr
    SSDPRSV
    upnphost
    CryptSvc
    Dnscache
    Tapisrv
    LanMan Station
    NlaSvc
    eventsystem
    netprofm
    nsi
    sstpsvc
    w32time
    wdiservicehost
    winmgmt
    themes
    shellhwdetection
    sens
    schedule
    rasman
    profsvc
    lanman server
    iphlpsvc
    ikeext
    gpsvc
    eaphost
    bits
    certprosvc
    aelooksvc
    audioendpoint builder
    hidserv
    netman
    pcasvc
    trkwks
    wlasnsvc
    wpdbusenum
    wudfsvc
    audiosrv
    dhcp
    eventlog
    lmhost
    wscscv
    rpcss
    rpceptmapper
    dcomlaunch
    plugplay
    power

    I have exhausted all means of solving my problem and has searched the net for all kinds of solution. I tried disabling them but since there are so many I do not know which are most likely to be causing my problem.
    At idle, my cpu runs at 50+ to 70+ and hits over 90/100 if during game play.

    Pls recommend ways to end my nightmare!!

    Thank you!
    Roy

    Kind regards

    Kasper

    1. Hi Roy,

      Sorry for the late reply.

      First of all, I assumed that you actually listed out all services running by svchost.exe (there are multiple instances running at the same time). You can try to narrow down your issue by identifying the svchost.exe that actually cause the high CPU usage. Then look for the services that it is involved. You can then try to disable one of them to see which is the culprit.

      Your issue could be related to Firefox, but it is not necessary the main cause.

      Rgds,
      Taylor

  18. In response to CHuBBNuTT’s post, I only 4 instead of 6.
    and i was unable to change the values to flase ->they appeared as numeric digit 45 and prompted that i cannot change the numder values to false?
    If u see my message, could you pls kindly assist me?
    Thank you!!

  19. Mine has this problem frequently, and I hate to go restart the upnphost service all the time, so instead i just created a task in the task scheduler to run a once a day, and repeat every 5 minutes. The task runs a .bat file:

    net stop upnphost
    net start upnphost

    if you want to make it run in the background without the cmd window coming up, run this .vbs with the above .bat already created as “C:\upnphost.bat”:

    Set WshShell = CreateObject(“WScript.Shell”)
    WshShell.Run chr(34) & “C:\upnphost.bat” & Chr(34), 0
    Set WshShell = Nothing

    this way the upnphost service will automatically restart every 5 minutes with no visible presentation, so if it decides to misbehave and go high cpu, it will be for 5 minutes tops, you could change this to any interval you want.

  20. The service that uses alot of CPU usage was the AudioEndpoint, and it gave me this message “The operation cannot be completed. A stop control has been sent to a service that other running services are dependent on.” Btw I am an administrator. Please Help.

    1. Hi Steve,

      It seems that the service you are trying to stop are dependent/depending to some other services, this is why it cannot be stopped directly. Check the dependency via services.msc at Run, then try to identify which services can be turn off to eliminate the high CPU issue.

      Rgds,
      Taylor

      1. hi Ghost301, i have some problems with this issue (100% cpu using by svchost.exe at w7), can you help me to solve it ?

      2. Hi,

        Please try the method that I used to identify the culprit, since different machines might have different cause of the issue. I am not able to help just by knowing the symptoms. Good luck!

        Rgds,
        Taylor

  21. Most adsl modems broadcast Unpn information so that devices can detect and connect. However, on some systems(XP) this will cause an svchost to continually poll this signal via a gateway. Results in the slow enexorable growth of that svc and consumption of memory. To fix, disable the unpn signal broadcast in the ADSL ROUTER.
    Paul

  22. Hi. my Computer is Windows 7
    i did what you did but i have still svchost.exe
    in the process tab.
    it is still harmful?

  23. Dear Sirs,

    I have encountered this problem when I used Oracle VirtualBox (since April 2011) on Windows7 Professional (64bit) — it is almost 100% reproducable!

    By looking at Task Manager, I noticed that svchost (upnohost) eats up CPU resource. Since I have no UPnP devices attached, I turned this service DISABLED.

    Just want to share my experience….
    Regards

  24. I solved it on my PC. I used to force restart upnphost service by pressing ctr+shift+esc then on performance tab > resource monitor and there go to CPU tab>Services>upnphost, right click and restart or stop service.
    That is a temporary fix and not a real one that deals with the problem. For me it was a matter of leaving the homegroup I tried to create and did not actually complete by adding the second PC. So the upnphost was waiting for the process to be completed on the other side.
    So now my PC works normally , and it worked instantly without restarting.
    Hope I helped.

  25. Hello, I had a simmilar problem (it started happening after a failed windows start). I cleaned my C drive with the windows cleanup tool and made sure to clear windows queued error reporting stuff and temporary files. I noticed it was constantly writing and reading to my hard disk (svchost.exe) and cleaning up my c drive made it stop.

    It could also be that i just had to wait for windows to complete something… I don’t know but it’s fixed for me :)

  26. Hey,
    after searching my laptop for hints, MY solution:
    for me it simply worked to unable a shared internet connection (hope it really is the solution). However, this may not be the reason for everyone.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s